岂止于建站

WordPress插件开发教程 – 设置插件必须兼容WP版本方法

我们网友是否有遇到过在安装或者升级某个WordPress插件的时候提示我们的WordPress版本比较低,需要升级到最新版本才可以使用这款插件。确实,我们在使用WordPress的时候还是建议保持与官方最新版本一致,这样从安全角度和软件支持角度还是必须的。

如果我们在需要做WordPress插件的时候,可以通过下面的方法设置插件兼容版本,如果低于WP某个版本就直接禁止启动插件,那是如何实现的呢?

<?php
register_activation_hook( __FILE__, 'boj_install');
function boj_install() {
if( version_compare( get_bloginfo( 'version' ), '5.2', '<' ) ) {
deactivate_plugins( basename( __FILE__ )); //禁用插件
}
}
?>

我们在启动安装插件的时候,通过get_bloginfo()函数来获取当前WP版本号,且通过version_compare()函数来验证兼容版本的对比。如果低于某个版本,直接deactivate_plugins()函数禁止插件。


关注公众号『老蒋部落』

获取更多建站运营运维新知!
互联网创业、前沿技术......

赞(0) 打赏
转载保留:老部落 » WordPress插件开发教程 – 设置插件必须兼容WP版本方法

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏